SuccessConsole Output

Started calculate disk usage of build
Finished Calculation of disk usage of build in 0 seconds
Started calculate disk usage of workspace
Finished Calculation of disk usage of workspace in 0 seconds
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building org.overture.ide.vdmrt.core 2.6.5-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] --- tycho-packaging-plugin:0.25.0:build-qualifier (default-build-qualifier) @ org.overture.ide.vdmrt.core ---
[INFO] The project's OSGi version is 2.6.5.201909041309
[TASKS] Scanning folder '/var/lib/jenkins/workspace/overture-test/ide/vdmrt/core' for files matching the pattern '**/*.java' - excludes: **/target/*
[TASKS] Found 3 files to scan for tasks
Found 2 open tasks.
[TASKS] Computing warning deltas based on reference build #198
[INFO] 
[INFO] --- tycho-packaging-plugin:0.25.0:validate-id (default-validate-id) @ org.overture.ide.vdmrt.core ---
[INFO] 
[INFO] --- tycho-packaging-plugin:0.25.0:validate-version (default-validate-version) @ org.overture.ide.vdmrt.core ---
[INFO] 
[INFO] --- maven-enforcer-plugin:1.0:enforce (enforce-maven) @ org.overture.ide.vdmrt.core ---
[INFO] 
[INFO] --- jacoco-maven-plugin:0.7.6.201602180812:prepare-agent (jacoco-initialize) @ org.overture.ide.vdmrt.core ---
[INFO] argLine set to -javaagent:/var/lib/jenkins/workspace/overture-test/.repository/org/jacoco/org.jacoco.agent/0.7.6.201602180812/org.jacoco.agent-0.7.6.201602180812-runtime.jar=destfile=/var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/target/coverage-reports/jacoco-unit.exec,excludes=**/org/overture/ast/analysis/**/*.*:**/org/overture/ast/expressions/**/*.*:**/org/overture/ast/modules/**/*.*:**/org/overture/ast/node/**/*.*:**/org/overture/ast/patterns/**/*.*:**/org/overture/ast/statements/**/*.*:**/org/overture/ast/types/**/*.*:**/org/overture/codegen/ir/**/*:**/org/overture/ide/**/*
[INFO] 
[INFO] --- maven-resources-plugin:2.7:resources (default-resources) @ org.overture.ide.vdmrt.core ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/src/main/resources
[INFO] 
[INFO] --- tycho-compiler-plugin:0.25.0:compile (default-compile) @ org.overture.ide.vdmrt.core ---
[INFO] Compiling 3 source files to /var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/target/classes
[WARNING] /var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/src/main/java/org/overture/ide/vdmrt/core/VdmRtCorePlugin.java:[89] 
	private final ListenerList shutdownListeners = new ListenerList();
	              ^^^^^^^^^^^^
ListenerList is a raw type. References to generic type ListenerList<E> should be parameterized
[WARNING] /var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/src/main/java/org/overture/ide/vdmrt/core/VdmRtCorePlugin.java:[89] 
	private final ListenerList shutdownListeners = new ListenerList();
	                                                   ^^^^^^^^^^^^
ListenerList is a raw type. References to generic type ListenerList<E> should be parameterized
2 problems (2 warnings)
[INFO] 
[INFO] --- maven-resources-plugin:2.7:testResources (default-testResources) @ org.overture.ide.vdmrt.core ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/src/test/resources
[INFO] 
[INFO] --- target-platform-configuration:0.25.0:target-platform (default-target-platform) @ org.overture.ide.vdmrt.core ---
[INFO] 
[INFO] --- tycho-packaging-plugin:0.25.0:package-plugin (default-package-plugin) @ org.overture.ide.vdmrt.core ---
[INFO] Building jar: /var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/target/org.overture.ide.vdmrt.core-2.6.5-SNAPSHOT.jar
[INFO] 
[INFO] --- tycho-p2-plugin:0.25.0:p2-metadata-default (default-p2-metadata-default) @ org.overture.ide.vdmrt.core ---
[INFO] 
[INFO] --- jacoco-maven-plugin:0.7.6.201602180812:report (jacoco-site) @ org.overture.ide.vdmrt.core ---
[INFO] Skipping JaCoCo execution due to missing execution data file:/var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/target/coverage-reports/jacoco-unit.exec
[INFO] 
[INFO] --- maven-javadoc-plugin:2.10.3:jar (attach-javadocs) @ org.overture.ide.vdmrt.core ---
[INFO] Skipping javadoc generation
[INFO] 
[INFO] --- maven-install-plugin:2.5.2:install (default-install) @ org.overture.ide.vdmrt.core ---
[INFO] Installing /var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/target/org.overture.ide.vdmrt.core-2.6.5-SNAPSHOT.jar to /var/lib/jenkins/workspace/overture-test/.repository/org/overturetool/ide/vdmrt/org.overture.ide.vdmrt.core/2.6.5-SNAPSHOT/org.overture.ide.vdmrt.core-2.6.5-SNAPSHOT.jar
[INFO] Installing /var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/pom.xml to /var/lib/jenkins/workspace/overture-test/.repository/org/overturetool/ide/vdmrt/org.overture.ide.vdmrt.core/2.6.5-SNAPSHOT/org.overture.ide.vdmrt.core-2.6.5-SNAPSHOT.pom
[INFO] Installing /var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/target/p2content.xml to /var/lib/jenkins/workspace/overture-test/.repository/org/overturetool/ide/vdmrt/org.overture.ide.vdmrt.core/2.6.5-SNAPSHOT/org.overture.ide.vdmrt.core-2.6.5-SNAPSHOT-p2metadata.xml
[INFO] Installing /var/lib/jenkins/workspace/overture-test/ide/vdmrt/core/target/p2artifacts.xml to /var/lib/jenkins/workspace/overture-test/.repository/org/overturetool/ide/vdmrt/org.overture.ide.vdmrt.core/2.6.5-SNAPSHOT/org.overture.ide.vdmrt.core-2.6.5-SNAPSHOT-p2artifacts.xml
[INFO] 
[INFO] --- tycho-p2-plugin:0.25.0:update-local-index (default-update-local-index) @ org.overture.ide.vdmrt.core ---
[INFO] 'org.overture.ide.vdmrt.core-2.6.5-SNAPSHOT-p2artifacts.xml' will not be deployed due to the defined include-exclude patterns.
[INFO] 'org.overture.ide.vdmrt.core-2.6.5-SNAPSHOT-p2metadata.xml' will not be deployed due to the defined include-exclude patterns.
[INFO] 'org.overture.ide.vdmrt.core-2.6.5-SNAPSHOT.jar' will not be deployed due to the defined include-exclude patterns.
[INFO] 'org.overture.ide.vdmrt.core-2.6.5-SNAPSHOT.pom' will not be deployed due to the defined include-exclude patterns.